Descript currently requires a Mac running macOS 10.11 (El Capitan) or greater.

Windows support is coming soon.

Did this answer your question?